Usar rutinas y funciones

Estimados alumnos:

He aquí que les dejo un trozo de código que sirve para manipular subprocesos o sub rutinas dentro de PSEint y VB.NET.

‘Con VB.NET
Module Module1

    Sub Saludar()
        Console.WriteLine(“Hola Mundo”)
    End Sub

    Function CalcularDoble(ByVal Valor As Integer) As Integer
        Valor = Valor * 2
        Return Valor ‘retornar el doble
    End Function

    Sub Triplicar(ByRef Valor As Integer)
        Valor = Valor * 3 ‘modifica la variable duplicando su valor
    End Sub

    ‘proceso principal, que invoca a las funciones antes declaradas
    Sub Main()
        Dim x As Integer
       
        Console.WriteLine(“LLamado a la rutina Saludar”)
        Saludar()
        Console.Write(“Ingrese valor para X: “)
        x = Console.ReadLine()
        Console.WriteLine(“Llamada a la función CalcularDoble (pasaje por valor)”)
        Console.WriteLine(“Doble de ” & x & ” es ” & CalcularDoble(x))
       
        Console.WriteLine(“Llamada a la función Triplicar (pasaje por referencia)”)
        Triplicar(x)
        Console.WriteLine(“El nuevo valor de X es: ” & x)

        Console.WriteLine(“Presione ENTER para terminar”)
        Console.ReadLine()
    End Sub

End Module

//Con PSEint
//proceso que no devuelve datos
SubProceso Saludar
 Escribir “Hola mundo!”
FinSubProceso

SubProceso res <- CalcularDoble(num)
 res <- num*2 // retorna el doble
FinSubProceso

SubProceso Triplicar(num por referencia)
 num <- num*3 // modifica la variable duplicando su valor
FinSubProceso

// proceso principal, que invoca a las funciones antes declaradas
Proceso PruebaFunciones
 Escribir “Llamada a la funcion Saludar:”
 Saludar()
 // como no recibe argumentos pueden omitirse los paréntesis vacios
 
 Escribir “Ingrese un valor numérico para x:”
 Leer x
 
 Escribir “Llamada a la función CalcularDoble (pasaje por valor)”
 Escribir “El doble de “,x,” es “, CalcularDoble(x)
 Escribir “El valor original de x es “,x
 
 Escribir “Llamada a la función Triplicar (pasaje por referencia)”
 Triplicar(x)
 Escribir “El nuevo valor de x es “, x
 
FinProceso

Contenido de la charla en el 4to Encuentro de Software Libre

Estimados y estimadas:

Aquí les dejo las diapositivas y el material para que puedan probar el área de los videojuegos.

Desde ya muchas gracias por asistir y será hasta la próxima 🙂

Programación de un videojuego 2D con Open Source

compilar juego en linux

Enlace del tutorial que inició el regreso al mundo de los videojuegos: http://www.linuxhispano.net/cursos/curso-programacion-de-videojuegos-con-sdl/

Material en Dropbox: (https://www.dropbox.com/s/uum7g0zujmy1rcu/1942.zip)

Videos atrasados para Programación Estructurada

Estimados alumnos:

He aquí que les iré dejando los videos (o sus enlaces respectivos)

Actualmente está listo el primer video que habla de condicionales. Este video lo podrán encontrar en: https://vimeo.com/76235576

(si acaso no aparece de inmediato esperen un poco, porque se toma una media hora en poder habilitarlo)

El video de condicionales 2 estará en el siguiente enlace: (https://vimeo.com/76236630)

El video de uso de cilos estará en el siguiente enlace: (pendiente)

Y el video de uso de cadenas estará en el siguiente enlace: (pendiente)

Saludos y sigan revisando la página que la iré actualizando entre hoy y mañana por la mañana.

Por cierto, los videos llevan sólo el trabajo con PSeInt. Luego dejaré el código de los ejercicios en PseInt y en VB.NET.

Hasta la próxima 🙂

 

Ejercicios resueltos en PseInt y Visual Basic

ejercicios vb

ejercicios pseint