Usar rutinas y funciones

Estimados alumnos:

He aquí que les dejo un trozo de código que sirve para manipular subprocesos o sub rutinas dentro de PSEint y VB.NET.

‘Con VB.NET
Module Module1

    Sub Saludar()
        Console.WriteLine(“Hola Mundo”)
    End Sub

    Function CalcularDoble(ByVal Valor As Integer) As Integer
        Valor = Valor * 2
        Return Valor ‘retornar el doble
    End Function

    Sub Triplicar(ByRef Valor As Integer)
        Valor = Valor * 3 ‘modifica la variable duplicando su valor
    End Sub

    ‘proceso principal, que invoca a las funciones antes declaradas
    Sub Main()
        Dim x As Integer
       
        Console.WriteLine(“LLamado a la rutina Saludar”)
        Saludar()
        Console.Write(“Ingrese valor para X: “)
        x = Console.ReadLine()
        Console.WriteLine(“Llamada a la función CalcularDoble (pasaje por valor)”)
        Console.WriteLine(“Doble de ” & x & ” es ” & CalcularDoble(x))
       
        Console.WriteLine(“Llamada a la función Triplicar (pasaje por referencia)”)
        Triplicar(x)
        Console.WriteLine(“El nuevo valor de X es: ” & x)

        Console.WriteLine(“Presione ENTER para terminar”)
        Console.ReadLine()
    End Sub

End Module

//Con PSEint
//proceso que no devuelve datos
SubProceso Saludar
 Escribir “Hola mundo!”
FinSubProceso

SubProceso res <- CalcularDoble(num)
 res <- num*2 // retorna el doble
FinSubProceso

SubProceso Triplicar(num por referencia)
 num <- num*3 // modifica la variable duplicando su valor
FinSubProceso

// proceso principal, que invoca a las funciones antes declaradas
Proceso PruebaFunciones
 Escribir “Llamada a la funcion Saludar:”
 Saludar()
 // como no recibe argumentos pueden omitirse los paréntesis vacios
 
 Escribir “Ingrese un valor numérico para x:”
 Leer x
 
 Escribir “Llamada a la función CalcularDoble (pasaje por valor)”
 Escribir “El doble de “,x,” es “, CalcularDoble(x)
 Escribir “El valor original de x es “,x
 
 Escribir “Llamada a la función Triplicar (pasaje por referencia)”
 Triplicar(x)
 Escribir “El nuevo valor de x es “, x
 
FinProceso

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s